蔦箱(蔦箱)

CentOS7でzabbix-serverがインストール出来ない.

ダウンロードするファイル間違えた。


2015 01 20

CentOS7でzabbixを導入している時に他はインストール出来たものの
zabbix-serverだけ依存関係のエラーでインストールすることが出来なかった。

requires libnetsnmp.so.20()(64bit)

な感じのエラーが表示されてzabbix-server-pgqlをインストールすることができなかった。
libnetsnmpをインストールし忘れたのかと思って、確認するとインストールが行われている。

調べたところ原因はCentOS7に適合しないzabbixのリポジトリ(rpm)を登録するという、アホな操作をしているせいだった。
RedHatLinux7(RHL)=CentOS7

ということでzabbixを一式アンインストールして
rpm -e zabbixうんたらかんたら.rpm

でリポジトリを削除した後。
yum clean all

rpm -ivh http://repo.zabbix.com/zabbix/2.4/rhel/7/x86_64/zabbix-release-2.4-1.el6.noarch.rpm
でzabbix-serverをインストールすることが出来た。


参考URL
[ZBXNEXT-2532] Dependency from libnetsnmp.so.20()(64bit) - ZABBIX SUPPORT




-サイトのコンテンツ-


記事
記事とか書きます.
新記事
新しい記事.
蔦箱(ツタハコ)
トップページ
作成物
作成した物とか置きます.
その他
適当


連絡先: